ComputerBasForum

Hier tips en tricks

Je bent niet ingelogd.

#1 2019-11-11 18:30:33

Bas
Administrator
Geregistreerd: 2019-11-10
Posts: 79

Webserver installeren?

Wat moet je wel en wat moet je niet doen?

WEL DOEN:
Begin met een schone installatie van je server en installeer de updates.
1. Maak een backup.
2. Maak een logboek van veranderingen na de backup.
3. Terug naar 1. enz...

Voer veranderingen altijd één voor één uit en controleer na elke verandering of alles goed gaat.

NIET DOEN:
-Teveel veranderingen tegelijk aanbrengen. Lees: meer dan 1.
Zo kom je er niet achter welke verandering een probleem heeft veroorzaakt als het mis gaat.
-Stappen overslaan.
Soms moeten er dingen veranderen in een exacte volgorde.
Als je hiervan afwijkt gaat het niet goed, fout of erger.
-Veranderingen aanbrengen die er voor zorgen dat je website of webserver onbereikbaar wordt.
Is niet handig maar je kan er wellicht iets van leren.

Succes!!

En dan nog dit:

Gebruik alleen TLSv1.2 en TLSv1.3

TLSv1.2 bestaat al sinds 2008 en alle browsers na 2012 ondersteunen het. TLSv1.3 is de nieuwste versie en wordt ondersteund door Mozilla Firefox en Google Chrome.

Cipher Suites:

Voor TLSv1.2:

In Apache:

ECDHE-RSA-AES256-GCM-SHA384
ECDHE-RSA-AES256-SHA384
ECDHE-RSA-CHACHA20-POLY1305
ECDHE-RSA-AES256-SHA

In IIS 10:

TLS_AES_256_GCM_SHA384
TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384
TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384
TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA

Voor TLSv1.3 in Apache:

nano /ect/openssl/openssl.conf

Voeg onderaan toe:

Ciphersuites = TLS_AES_256_GCM_SHA384:TLS_CHACHA20_POLY1305_SHA256

Dit is niet volgens de manual RFC 8446 Section 9.1:

https://datatracker.ietf.org/doc/html/r … ection-9.1

"A TLS-compliant application MUST implement the TLS_AES_128_GCM_SHA256 cipher suite"

Feit is dat voor de TLS handshakes de TLS_AES_128_GCM_SHA256 cipher suite niet nodig is. Door deze niet meer te vereisen voor RFC 8446 Section 9.1 kan TLSv1.3 ook voldoen aan de eis van AES256 encryptie.

Offline

Forum footer

Powered by FluxBB 1.5.11